CERCA VERTICALE EXCEL

Utilizzare la Funzione Cerca Verticale di Excel

La funzione CERCA VERTICALE EXCEL (cerca.vert) consente di individuare un valore, sia esso di carattere testuale che numerico o alfanumerico, presente all’interno di una matrice dati e restituirne il relativo valore, nelle modalità consentite dalla funzione stessa.

Il Cerca Verticale è sicuramente una funzione di grande utilità e fino a poco tempo fa, era tra le più usate tra i neofiti di Excel, sia per necessità, sia per facilità di utilizzo.

In realtà questa istruzione nasconde dei limiti molto importanti, in parte superati con la “Funzione Indice” (che vedremo in altri articoli). Nonostante questa evoluzione della ricerca, gli sviluppatori Excel, non ancora soddisfatti dell’evoluzione del Cerca Verticale, hanno recentemente creato “La funzione cerca x” che si ripromette di superare ogni ostacolo dettato da funzioni adibite alla ricerca di criteri all’interno di un database.

Dopo questa rapida introduzione alla funzione principe di Excel, vediamone la relativa sintassi di inserimento:

=CERCA.VERT(valore; matrice_tabella; indice; [intervallo])

Non lasciarti spaventare da quanto appena letto; in realtà l’utilizzo del Cerca Verticale è veramente elementare e, a differenza di altri portali del settore, noi trattiamo gli argomenti in modo diretto e senza rendere troppo difficile quello che non serve. Quindi, come di consueto, massima chiarezza nell’esposizione di ciò che andremo a trattare.

Nell’immagine che segue, vedrai una semplicissima tabella dati (comunemente chiamata database) e su questa, noi vogliamo estrapolare un determinato valore e fare in modo che questo venga restituito nella forma consentita dalla funzione Cerca Verticale, in modo da poterlo elaborare a seconda delle nostre necessità.

Tali necessità non sono argomento di questo articolo .. ma come utilizzare la funzione è lo scopo di quanto stai leggendo, quindi procediamo con una spiegazione al riguardo.

Tabella Cerca Verticale

Ecco la tanto temuta tabella o database se preferisci; dentro di essa ci sono i dati, come Nome Cliente, Progetto, Fattura, ecc ..
Tutti i dati presenti dentro questo piccola tabella, vengono definiti come una “matrice dati” e come vedi non c’è nulla di astratto dietro certe terminologie.

Con la funzione Cerca Verticale, noi andremo a prelevare un determinato dato presente all’intero della tabella (nello specifico Fattura, Valore e Data Emissione) e lo porteremo all’intero del nostro foglio di calcolo Excel.

Per farlo, useremo la temuta sintassi sopra esposta, tenendo sempre a mente queste due considerazione fondamentali, che sono essenziali per avere un ritorno corretto del risultato e che determinano i limiti della funzione, come sopra anticipato.

1- Il nostro valore di riferimento deve essere sempre il primo a sinistra di tutti i dati che andremo a ricercare nella matrice.
Cerca Verticale legge i valori da sinistra a destra, quindi, se dovessimo rintracciare un valore a sinistra del riferimento che andremo ad inserire, questo non verrebbe trovato e avremo un messaggio di errore dettato da Excel.
2- I valori che andremo a ricercare, dovranno essere SEMPRE UNIVOCI. La funzione Cerca Verticale è pigra e appena trova il valore da noi dichiarato si ferma !! Quindi se nel database dovessero essere presenti due fatture con il medesimo nome, a noi verrebbe restituito soltanto il primo risultato. Esistono modi per risolvere questo inconveniente, ma non sono argomenti che tratteremo in questo articolo.

SINTASSI E FORMULA CERCA VERTICALE PER RINTRACCIARE UNA FATTURA ALL’INTERNO DI UN DATABASE

Tabella Cerca Verticale

=CERCA.VERT(valore; matrice_tabella; indice; [intervallo])
=CERCA.VERT($A13;$C$2:$E$10;2;0) (Formula)

Cerca verticale
Passiamo alla spiegazione della formula, posto che alcune argomentazioni per chi si avvicina soltanto oggi ad Excel, saranno nuove e quindi poco comprensibili.

VALORE: Il riferimento che ci viene chiesto non è altro che il dato che noi vogliamo ricercare all’interno di una determinata matrice di riferimento;
Il valore sarà dato dalla cella A13$ (bloccata per le colonne) in quanto conterrà il nominativo della fattura, selezionata attraverso la convalida dati.

MATRICE_TABELLA è l’intervallo che contiene tutti i dati in essere, nei quali, andremo a rintracciare anche il nostro valore di riferimento. Procederemo a selezionare tutta la relativa area;
Per noi la matrice dati, sarà composta da tutti i valori presenti nella tabella. Quindi l’intervallo verrà indicato come C$2:$E$10 (Blocco assoluto per la matrice)

INDICE: E’ il riferimento di colonna, nella quale, il nostro dato è racchiuso e va indicato con un numero pari a quello della colonna che lo contiene. Quindi, “Indice 2” sta ad indicare, che il valore da noi ricercato si trova nella Colonna D. Consideriamo che noi abbiamo selezionato la matrice dalla colonna C in poi, per via dell’impossibilità di leggere i dati della funzione Cerca Verticale a sinistra della matrice di origine.

INTERVALLO: Da notare che tale riferimento è racchiuso fra parantesi quadre […] il che sta a significare, che il suo inserimento sarà sempre facoltativo da parte dell’operatore. Questa considerazione vale per tutte le sintassi, dove lo screen-tip ci indica il passaggio nel modo appena descritto.
Tale “Intervallo” anche se non obbligatorio è di fondamentale utilizzo, quando si parla di Cerca Verticale Excel.

Si tratta di un semplice valore logico, dove “0” corrisponde ad una ricerca esatta (quella che a noi interessa utilizzando la funzione cerca verticale) e dove “1” corrisponde ad una ricerca approssimativa. Quest’ultima è di scarso interesse, anzi, è da NON considerare nell’utilizzo di tale funzione Excel.

Per il momento non aggiungiamo altro, visto che il criterio di ricerca di approssimazione, sarà argomento di numerosi discussione anche in numerose altre funzioni Excel.

<< Potete scaricare il foglio da esempio Excel con la ricerca effettuata con la funzione Cerca Verticale >>

Per il test è stato utilizzata la versione Office365 Excel 2016

INFO DATI TAB PIVOT

La funzione INFO DATI TAB PIVOT trova la sua utilità nel recuperare ed estrapolare dati da una tabella Pivot.

Ecco la sintassi della funzione INFO DATI TAB PIVOT

INFO.DATI.TAB.PIVOT(campo_dati; tabella_pivot; [campo1; elemento1; campo2; elemento2]; …)

ARGOMENTI DELLA FUNZIONE

  • ARGOMENTI DELLA FUNZIONE:
  • campo_dati – Il nome del campo da interrogare;
  • tabella_pivot – Un riferimento a qualsiasi cella della tabella pivot da interrogare;
  • campo1, elemento1 – [opzionale] Una coppia campo/elemento.

Per capire la verità utilità di questa funzione Excel, è necessario conoscere la dinamica, nonchè l’utilità delle Pivot Tables. In mancanza di queste informazioni al riguardo, difficilmente si riuscirà ad apprendere in modo completo le dinamiche di questa funzione.

Nel caso, rimando l’utente interessato, ad un’attenta lettura delle Tabelle Pivot e della loro funzione ed utilità in ambiente Microsoft Excel, per graficare e creare Report di uso professionale.

UTILIZZO PRATICO FUNZIONE INFO DATI TAB PIVOT

Quando si crea una tabella Pivot, attraverso filtri e slicers dinamici, può risultare di grande utilità, avere un estratto dati in forma statica, che sia ben visibile e presente agli occhi dell’operatore e dei destinatari di tale compendio grafico.

Possiamo utilizzare la funzione INFO.DATI.TAB.PIVOT per interrogare una tabella Pivot creata e recuperate determinati dati in base alla struttura della stessa.

Il primo argomento che viene richiesto è il “Campo Dati” che indica il valore da interrogare attraverso la funzione. Il successivo argomento richiestoci dalla sintassi è il nome della “Tabella Pivot” in essere.

Ulteriori argomenti, vengono richiesti per filtrare e/o recuperare i dati sulla struttura della Tabella Pivot.

Importante: Prima di utilizzare la funzione INFO.DATI.TAB.PIVOT assicurarsi di aver spuntato la relativa opzione di attivazione.

Processo: Selezionare una qualsiasi cella della tabella Pivot, quindi andare su “Analizza” in alto, nel menù interfaccia utente, quindi spuntare la voce “Genera INFO.DATI.TAB.PIVOT” (Come da immagine in Microsoft versione Office 365).

La struttura grafica può variare a seconda della funzione utilizzata.

IMMAGINE ESEMPIO FUNZIONE INFO DATI TAB PIVOT (MICROSOFT EXCEL VERSIONE OFFICE 365)

<< Ulteriori risorse funzione INFO.DATI.TAB.PIVOT direttamente al sito del produttore. Ecco il relativo Link alla guida in linea di Office >>

Articolo redatto dal sito Facilexcel.it